mirror of
https://github.com/openwrt/packages.git
synced 2025-02-20 17:56:12 +00:00
hcxtools: update to 6.3.2
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
net/hcxtools
@ -8,18 +8,19 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=hcxtools
|
||||
PKG_VERSION:=6.2.4
|
||||
PKG_VERSION:=6.3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxtools/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=74299313dd15ed38f07b42201903ab85ebbc3ad220a01fff1bd5c967cfea817d
|
||||
PKG_HASH:=555e46a59df6a77c5aa73b99ffa8c1e84fa79e24ffaf5180de1d3a7f4ab7a470
|
||||
|
||||
PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=license.txt
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/hcxtools
|
||||
SECTION:=net
|
||||
@ -35,27 +36,17 @@ define Package/hcxtools/description
|
||||
for the use with latest hashcat or John the Ripper.
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/ \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)"
|
||||
endef
|
||||
|
||||
define Package/hcxtools/install
|
||||
$(INSTALL_DIR) $(1)/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxeiutool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxessidtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhash2cap $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashcattool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxmactool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcapngtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpmkidtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpmktool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpsktool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxwltool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/whoismac $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/sbin/
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/hcxeiutool $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/hcxhash2cap $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/hcxhashtool $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/hcxpcapngtool $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/hcxpmktool $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/hcxpsktool $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/hcxwltool $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/whoismac $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/wlancap2wpasec $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,hcxtools))
|
||||
|
@ -1,85 +0,0 @@
|
||||
--- a/hcxhashtool.c
|
||||
+++ b/hcxhashtool.c
|
||||
@@ -107,9 +107,6 @@ static void closelists()
|
||||
{
|
||||
if(hashlist != NULL) free(hashlist);
|
||||
if(ouilist != NULL) free(ouilist);
|
||||
-EVP_cleanup();
|
||||
-CRYPTO_cleanup_all_ex_data();
|
||||
-ERR_free_strings();
|
||||
return;
|
||||
}
|
||||
/*===========================================================================*/
|
||||
@@ -128,8 +125,6 @@ eapolwrittencount = 0;
|
||||
essidwrittencount = 0;
|
||||
hccapxwrittencount = 0;
|
||||
hccapwrittencount = 0;
|
||||
-ERR_load_crypto_strings();
|
||||
-OpenSSL_add_all_algorithms();
|
||||
if((hashlist = (hashlist_t*)calloc(hashlistcount, HASHLIST_SIZE)) == NULL) return false;
|
||||
if((ouilist = (ouilist_t*)calloc(ouilistcount, OUILIST_SIZE)) == NULL) return false;
|
||||
return true;
|
||||
--- a/hcxpcapngtool.c
|
||||
+++ b/hcxpcapngtool.c
|
||||
@@ -366,9 +366,6 @@ if(eapmschapv2msglist != NULL) free(eapm
|
||||
if(eapmschapv2hashlist != NULL) free(eapmschapv2hashlist);
|
||||
if(tacacsplist != NULL) free(tacacsplist);
|
||||
|
||||
-EVP_cleanup();
|
||||
-CRYPTO_cleanup_all_ex_data();
|
||||
-ERR_free_strings();
|
||||
return;
|
||||
}
|
||||
/*===========================================================================*/
|
||||
@@ -377,8 +374,6 @@ static bool initlists()
|
||||
static unsigned long opensslversion;
|
||||
static const char nastring[] = { "N/A" };
|
||||
|
||||
-ERR_load_crypto_strings();
|
||||
-OpenSSL_add_all_algorithms();
|
||||
opensslversion = OpenSSL_version_num();
|
||||
opensslversionmajor = (opensslversion & 0x10000000L) >> 28;
|
||||
opensslversionminor = (opensslversion & 0x01100000L) >> 20;
|
||||
--- a/hcxpmktool.c
|
||||
+++ b/hcxpmktool.c
|
||||
@@ -923,8 +923,6 @@ while((auswahl = getopt_long(argc, argv,
|
||||
}
|
||||
}
|
||||
|
||||
-ERR_load_crypto_strings();
|
||||
-OpenSSL_add_all_algorithms();
|
||||
printf("\n");
|
||||
if((essidstring != NULL) && (pskstring != NULL) && (pmkstring == NULL) && (hashlinestring == NULL))
|
||||
{
|
||||
@@ -956,9 +954,6 @@ else if((essidstring != NULL) && (pskstr
|
||||
}
|
||||
|
||||
printf("\n");
|
||||
-EVP_cleanup();
|
||||
-CRYPTO_cleanup_all_ex_data();
|
||||
-ERR_free_strings();
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
/*===========================================================================*/
|
||||
--- a/hcxpsktool.c
|
||||
+++ b/hcxpsktool.c
|
||||
@@ -63,8 +63,6 @@ essidglen = 32;
|
||||
t = time(NULL);
|
||||
tm = localtime(&t);
|
||||
thisyear = tm->tm_year +1900;
|
||||
-ERR_load_crypto_strings();
|
||||
-OpenSSL_add_all_algorithms();
|
||||
return;
|
||||
}
|
||||
/*===========================================================================*/
|
||||
@@ -2832,10 +2830,6 @@ if(pskname != NULL)
|
||||
fclose(fhpsk);
|
||||
}
|
||||
|
||||
-EVP_cleanup();
|
||||
-CRYPTO_cleanup_all_ex_data();
|
||||
-ERR_free_strings();
|
||||
-
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
/*===========================================================================*/
|
Reference in New Issue
Block a user