Port srelay to -ng
SVN-Revision: 4537
This commit is contained in:
net/srelay
56
net/srelay/Makefile
Normal file
56
net/srelay/Makefile
Normal file
@ -0,0 +1,56 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=srelay
|
||||
PKG_VERSION:=0.4.6
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=4a9f3298b38d8588f0ffde31b946a47f
|
||||
|
||||
PKG_SOURCE_URL:=@SF/socks-relay
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
PKG_INIT_LEVEL:=60
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/srelay
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=A socks 4/5 proxy server
|
||||
DESCRIPTION:=A socks 4/5 protocol proxy server
|
||||
URL:=http://www.c-wind.com/srelay/
|
||||
endef
|
||||
|
||||
define Package/srelay/conffiles
|
||||
/etc/srelay.conf
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,--disable-thread)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default, CC=$(TARGET_CC) \
|
||||
all)
|
||||
endef
|
||||
|
||||
define Package/srelay/install
|
||||
install -m0755 -d $(1)/usr/bin
|
||||
install -m0755 -d $(1)/etc/init.d
|
||||
$(CP) $(PKG_BUILD_DIR)/srelay $(1)/usr/bin/
|
||||
$(CP) files/srelay.init $(1)/etc/init.d/S$(PKG_INIT_LEVEL)srelay
|
||||
$(CP) files/srelay.conf $(1)/etc
|
||||
chmod 755 $(1)/etc/init.d/S$(PKG_INIT_LEVEL)srelay
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,srelay))
|
2
net/srelay/files/srelay.conf
Normal file
2
net/srelay/files/srelay.conf
Normal file
@ -0,0 +1,2 @@
|
||||
# allow local subnet to access socks proxy
|
||||
192.168.1.0/24 any -
|
5
net/srelay/files/srelay.init
Executable file
5
net/srelay/files/srelay.init
Executable file
@ -0,0 +1,5 @@
|
||||
#!/bin/sh
|
||||
|
||||
if [ -f /etc/srelay.conf ];then
|
||||
srelay -c /etc/srelay.conf -r -s
|
||||
fi
|
12
net/srelay/patches/01-cross_compile.patch
Normal file
12
net/srelay/patches/01-cross_compile.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -urN srelay-0.4.6/configure srelay-0.4.6.new/configure
|
||||
--- srelay-0.4.6/configure 2003-04-14 07:36:15.000000000 +0200
|
||||
+++ srelay-0.4.6.new/configure 2006-03-28 15:11:42.000000000 +0200
|
||||
@@ -1395,7 +1395,7 @@
|
||||
;;
|
||||
linux*)
|
||||
case "$build_cpu" in
|
||||
- i*86)
|
||||
+ i*86 | mips* | powerpc* | sparc*)
|
||||
OS=LINUX
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define LINUX 1
|
Reference in New Issue
Block a user