0
0
mirror of https://github.com/termux-pacman/glibc-packages.git synced 2025-02-24 09:45:01 +00:00

36 lines
1.2 KiB
Bash

# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: ice-man <icemanf@gmail.com>
pkgname=libssh2-glibc
pkgver=1.10.0
pkgrel=0
pkgdesc="A library implementing the SSH2 protocol as defined by Internet Drafts"
url="https://www.libssh2.org/"
arch=(any)
license=('BSD')
validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2' # Daniel Stenberg
'914C533DF9B2ADA2204F586D78E11C6B279D5C91') # Daniel Stenberg (old key)
source=("https://www.libssh2.org/download/libssh2-$pkgver.tar.gz"{,.asc})
sha256sums=('2d64e90f3ded394b91d3a2e774ca203a4179f69aebee03003e5a6fa621e41d51'
'SKIP')
build() {
cd "libssh2-$pkgver"
CFLAGS="-Wl,-rpath=/data/data/com.termux/files/usr/glibc/lib -Wl,--dynamic-linker=/data/data/com.termux/files/usr/glibc/lib/ld-linux-aarch64.so.1"
CXXFLAGS="${CFLAGS}"
./configure --prefix=/data/data/com.termux/files/usr/glibc
make
}
package() {
cd "libssh2-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir/data/data/com.termux/files/usr/glibc/share/licenses/$pkgname/LICENSE"
}