mirror of
https://github.com/termux-pacman/glibc-packages.git
synced 2025-02-24 09:45:01 +00:00
35 lines
1.0 KiB
Bash
35 lines
1.0 KiB
Bash
# Maintainer: Anatol Pomozov
|
|
# Contributor: Zhuoyun Wei <wzyboy@wzyboy.org>
|
|
|
|
pkgname=libnghttp2-glibc
|
|
pkgver=1.47.0
|
|
pkgrel=0
|
|
pkgdesc='Framing layer of HTTP/2 is implemented as a reusable C library'
|
|
arch=(any)
|
|
url='https://nghttp2.org/'
|
|
license=(MIT)
|
|
source=(https://github.com/nghttp2/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz)
|
|
sha512sums=('ad6266a15789fec966db6be8ac0b9ee6cca257a3bb91fdd34a58acf0e472643a571941b5974d16c98f6ac5bfa6a03c4b70a6dff222fb0cd50909178b7e94ce48')
|
|
|
|
build() {
|
|
cd nghttp2-$pkgver
|
|
|
|
CFLAGS="-Wl,-rpath=/data/data/com.termux/files/usr/glibc/lib -Wl,--dynamic-linker=/data/data/com.termux/files/usr/glibc/lib/ld-linux-aarch64.so.1"
|
|
CXXFLAGS="${CFLAGS}"
|
|
|
|
autoreconf -i
|
|
./configure \
|
|
--prefix=/data/data/com.termux/files/usr/glibc \
|
|
--disable-examples \
|
|
--disable-python-bindings \
|
|
--enable-lib-only
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd nghttp2-$pkgver/lib
|
|
|
|
make DESTDIR="$pkgdir" install
|
|
install -Dm644 ../COPYING "$pkgdir/data/data/com.termux/files/usr/glibc/share/licenses/libnghttp2/COPYING"
|
|
}
|