0
0
mirror of https://github.com/jellyfin/jellyfin-web.git synced 2025-04-02 00:19:17 +00:00
Files
jellyfin-web/flake.nix
Jakob Stechow 5d0e85bf0e Add a basic nix flake for development (#6531)
* feat: add a basic nix flake

* fix: dev server on nixos
2025-03-03 14:14:24 -05:00

35 lines
765 B
Nix

{
description = "jellyfin-web nix flake";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = {
self,
nixpkgs,
flake-utils,
}:
flake-utils.lib.eachDefaultSystem (
system: let
pkgs = import nixpkgs {
inherit system;
};
in {
devShell = with pkgs;
mkShell rec {
buildInputs = [
nodejs_20
];
shellHook = ''
# Also see: https://github.com/sass/embedded-host-node/issues/334
echo "Removing sass-embedded from node-modules as its broken on NixOS."
rm -rf node_modules/sass-embedded*
'';
};
}
);
}