From ea6e774521cdfc830036800fbeb5e3c646e466f6 Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jow@openwrt.org>
Date: Sat, 24 Jul 2010 15:47:15 +0000
Subject: [PATCH] [package] base-files: unconditionally unlock the rootfs_data
 partition (#7437)

SVN-Revision: 22377
---
 package/base-files/Makefile                         | 2 +-
 package/base-files/files/lib/preinit/40_mount_jffs2 | 1 +
 2 files changed, 2 insertions(+), 1 deletion(-)

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 24bbf188c3..137eb62a2f 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=50
+PKG_RELEASE:=51
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
diff --git a/package/base-files/files/lib/preinit/40_mount_jffs2 b/package/base-files/files/lib/preinit/40_mount_jffs2
index cb743ea75c..d2f05b02ce 100644
--- a/package/base-files/files/lib/preinit/40_mount_jffs2
+++ b/package/base-files/files/lib/preinit/40_mount_jffs2
@@ -5,6 +5,7 @@
 find_mount_jffs2() {
 	mkdir -p /tmp/overlay
     mount "$(find_mtd_part rootfs_data)" /tmp/overlay -t jffs2
+    mtd -qq unlock rootfs_data
 }
 
 jffs2_not_mounted() {