From 151cadfe32b022b9fc59cb80986bf15c2f5022c4 Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Fri, 19 Apr 2013 08:07:34 +0000
Subject: [PATCH] kernel: update linux 3.8 to 3.8.8

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 36363
---
 include/kernel-version.mk                                     | 4 ++--
 target/linux/adm5120/Makefile                                 | 2 +-
 target/linux/ar71xx/Makefile                                  | 2 +-
 target/linux/atheros/Makefile                                 | 2 +-
 target/linux/avr32/Makefile                                   | 2 +-
 target/linux/cns21xx/Makefile                                 | 2 +-
 target/linux/cns3xxx/Makefile                                 | 2 +-
 target/linux/ep93xx/Makefile                                  | 2 +-
 target/linux/generic/patches-3.8/950-vm_exports.patch         | 2 +-
 target/linux/lantiq/Makefile                                  | 2 +-
 target/linux/malta/Makefile                                   | 2 +-
 target/linux/mpc52xx/Makefile                                 | 2 +-
 target/linux/mpc83xx/Makefile                                 | 2 +-
 target/linux/mpc85xx/Makefile                                 | 2 +-
 target/linux/mvebu/Makefile                                   | 2 +-
 target/linux/ppc40x/Makefile                                  | 2 +-
 target/linux/ppc44x/Makefile                                  | 2 +-
 target/linux/ramips/Makefile                                  | 2 +-
 .../0209-owrt-GPIO-add-gpio_export_with_name.patch            | 2 +-
 target/linux/rb532/Makefile                                   | 2 +-
 target/linux/realview/Makefile                                | 2 +-
 target/linux/uml/Makefile                                     | 2 +-
 target/linux/x86/alix2/target.mk                              | 2 +-
 target/linux/x86/generic/target.mk                            | 2 +-
 target/linux/xburst/Makefile                                  | 2 +-
 25 files changed, 26 insertions(+), 26 deletions(-)

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index b565df3e44..2eb73cedcc 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -11,8 +11,8 @@ endif
 ifeq ($(LINUX_VERSION),3.7.10)
   LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
 endif
-ifeq ($(LINUX_VERSION),3.8.7)
-  LINUX_KERNEL_MD5SUM:=37ce9b5cc33551b45fea59c1c4c9da13
+ifeq ($(LINUX_VERSION),3.8.8)
+  LINUX_KERNEL_MD5SUM:=3b4feff68460881a5dde1307fe1ce87f
 endif
 
 # disable the md5sum check for unknown kernel versions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index 6a58a25e42..3910a85942 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 746b4be28c..fa698a446e 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
index a5b2d093f3..2b77032237 100644
--- a/target/linux/atheros/Makefile
+++ b/target/linux/atheros/Makefile
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index cec5ae400d..7896202232 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/cns21xx/Makefile b/target/linux/cns21xx/Makefile
index 05436e4796..d851ba2cb0 100644
--- a/target/linux/cns21xx/Makefile
+++ b/target/linux/cns21xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/cns3xxx/Makefile b/target/linux/cns3xxx/Makefile
index 6b5b45b7ff..c604ea85c7 100644
--- a/target/linux/cns3xxx/Makefile
+++ b/target/linux/cns3xxx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ep93xx/Makefile b/target/linux/ep93xx/Makefile
index 8ad8318204..80b8fcc4b9 100644
--- a/target/linux/ep93xx/Makefile
+++ b/target/linux/ep93xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 DEVICE_TYPE:=developerboard
 
diff --git a/target/linux/generic/patches-3.8/950-vm_exports.patch b/target/linux/generic/patches-3.8/950-vm_exports.patch
index 66015992c1..9c15a1b813 100644
--- a/target/linux/generic/patches-3.8/950-vm_exports.patch
+++ b/target/linux/generic/patches-3.8/950-vm_exports.patch
@@ -62,7 +62,7 @@
  
 --- a/mm/memory.c
 +++ b/mm/memory.c
-@@ -1408,6 +1408,7 @@ void zap_page_range(struct vm_area_struc
+@@ -1409,6 +1409,7 @@ void zap_page_range(struct vm_area_struc
  	mmu_notifier_invalidate_range_end(mm, start, end);
  	tlb_finish_mmu(&tlb, start, end);
  }
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 87827fe185..e042ca4d31 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index efac73e3ab..6161443d93 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 DEVICE_TYPE:=developerboard
 
diff --git a/target/linux/mpc52xx/Makefile b/target/linux/mpc52xx/Makefile
index 9d894e6022..e06ff6a57a 100644
--- a/target/linux/mpc52xx/Makefile
+++ b/target/linux/mpc52xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/mpc83xx/Makefile b/target/linux/mpc83xx/Makefile
index b302089900..fa30ecf5fe 100644
--- a/target/linux/mpc83xx/Makefile
+++ b/target/linux/mpc83xx/Makefile
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 319dd4d0e6..9e5109efd8 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index 22fd05a737..4c49e2757b 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 8f9b9b6103..27e1a14170 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index 10c9f75f87..9612e90d59 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index b78a00174c..43520abe96 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
diff --git a/target/linux/ramips/patches-3.8/0209-owrt-GPIO-add-gpio_export_with_name.patch b/target/linux/ramips/patches-3.8/0209-owrt-GPIO-add-gpio_export_with_name.patch
index c8b16dc790..efbd0858d6 100644
--- a/target/linux/ramips/patches-3.8/0209-owrt-GPIO-add-gpio_export_with_name.patch
+++ b/target/linux/ramips/patches-3.8/0209-owrt-GPIO-add-gpio_export_with_name.patch
@@ -91,7 +91,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  /* Private data structure for of_gpiochip_find_and_xlate */
  struct gg_data {
-@@ -289,3 +291,62 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -288,3 +290,62 @@ void of_gpiochip_remove(struct gpio_chip
  	if (chip->of_node)
  		of_node_put(chip->of_node);
  }
diff --git a/target/linux/rb532/Makefile b/target/linux/rb532/Makefile
index 5b55afa4de..270830806e 100644
--- a/target/linux/rb532/Makefile
+++ b/target/linux/rb532/Makefile
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index 718141b8e7..801b3fde7b 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 DEVICE_TYPE:=developerboard
 
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index a10f0dd17b..650a0bebee 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index fcd7a2377b..06605fcfdf 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
 			kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
 			kmod-ledtrig-netdev \
 			kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
diff --git a/target/linux/x86/generic/target.mk b/target/linux/x86/generic/target.mk
index a5ac323f7b..31dfa5167d 100644
--- a/target/linux/x86/generic/target.mk
+++ b/target/linux/x86/generic/target.mk
@@ -1,6 +1,6 @@
 BOARDNAME:=Generic
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 define Target/Description
 	Build firmware images for x86 based boards
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index 143dce41ec..8b6dd1c500 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio broken
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 DEVICE_TYPE=other